NEW FEATURE: Post Like system!!!

At long last, we have successfully implemented a comprehensive post rating/like system. With casual readers and visitors vastly outnumbering frequent posters, it is not always apparent to users that others are reading, enjoying and grateful for their posts. If you are too shy to post and want to express your thanks, now you can!

Liking a post is easy - click this thumbs up in the top right hand corner of the post: Image

Can I encourage everyone to use this new feature enthusiastically and liberally and be sure to go back to your favourite old topics and like old posts. This will help build up useful user 'like' profiles and give credit to the users who has provided so much value to this community. This in turn helps guests and newcomers sort useful answers and posters from others.

This goes to regular forum lurkers especially - please show your appreciation with a 'like'!

Featuring:
  • Liked post counters in every user profile (given & received)
  • Liked post leaderboard accessible from the index and Quick Links Menu
  • Receive notifications when your post is liked, configurable from the User Control Panel (in forum notification and/or email notifications available or off)
  • You can remove a like if you made a mistake by clicking the undo button where the thumbs up used to sit (but the user will be notified)
  • Plus more


Read the announcement and post any queries, comments or suggestions HERE

Once read, this announcement can be dismissed by clicking on the 'X' in the top right hand corner.

2000 rx7 fd 13b help please!

Topics specific to rotary engines, cars and car-related issues.
eg: automotive news, concepts, car shows, etc.

Moderators: wotmazda, 7rex, KILLA 13B, matty

Post Reply
Message
Author
Nocluehaha
Registered Rotor User
Posts: 2
Joined: Tue Sep 05, 2017 10:04 pm
Has liked: 0
Been liked: 0

2000 rx7 fd 13b help please!

#1 Post by Nocluehaha » Tue Sep 05, 2017 10:22 pm

Hey guys sorry as it shows I have 'no clue' haha and I hope I am posting in the right but.

So yea I have a 2000 rx7 13b. Has 110 on it.

Randomly a few months ago it developed this problem and it's got to the point it happens every start now I'll explain what's happening just thought i would get that bit out the way.

So when I start the car and drive off, as soon as I get to 2000/2500 revs the car almost feels like it's dying and I get no power. Just before the turbo would move off the -4 to 0 on the gauge. No matter what gear I am in it gets to there and I lose power and the exhaust pops a little. When I pull over and turn the car on and off, or drive in second, turn the ignition on and off and drop the clutch to start it, it goes back to being perfect. Turbo kicks in fine and it flies. But as soon as I turn it off, even on a servo run, I have to do this again. It almost feels like as soon as the turbo would start trying to work it dies in the ass. I liken it to the same feeling as when the fuel pump went on my 180(but at least I could power through that).


Has this ever happened to anyone before? Or any suggestions? Someone has mentioned solenoids or maybe a computer management problem but I don't know how just roll starting a car would 'fix' a comp issue.

Any and all help would be appreciated.

Thanks



Nocluehaha
Registered Rotor User
Posts: 2
Joined: Tue Sep 05, 2017 10:04 pm
Has liked: 0
Been liked: 0

Re: 2000 rx7 fd 13b help please!

#2 Post by Nocluehaha » Wed Sep 06, 2017 12:55 pm

Turns out as well the first turbo isn't kicking in or doing anything really. It gets barely above the 0 line on the dash and not till 4500/5000 does the second turbo kick in.



Post Reply