Forum announcement - 13 April 2018 - some images on the forum are hosted by a service called PostImage. PostImage had their primary domain name suspended so any links to images hosted on that server are temporarily unavailable. The good news is that images are still available on the Internet, but instead of being hosted at postimg.org, they are at postimg.cc. We can probably fix this at our end by automatically amending all PostImage URLs in the database to point to the location, but I'm hoping PostImage will sort this out themselves. In the meantime, you can view the images by manually changing the URLs from postimg.org to postimg.cc. Thanks!

RX-7 Starting issues.

Topics specific to rotary engines, cars and car-related issues.
eg: automotive news, concepts, car shows, etc.

Moderators: KILLA 13B, wotmazda, 7rex

Post Reply
Message
Author
kizzawulf9
Registered Rotor User
Posts: 7
Joined: Sat Mar 25, 2017 12:03 am
Has liked: 0
Been liked: 0

RX-7 Starting issues.

#1 Post by kizzawulf9 » Sun Apr 16, 2017 5:40 pm

Hey guys, posting this for a mate of mine.

Car is having issues starting.
It's a 2001 RZ, engine just got a rebuild and is at about 1,000kms.
I wanted to help but as i am still learning about rotaries i thought it would be a better idea to ask people a little more experienced.
Any information i could pass on would be great, thanks in advance.

Videos of car:
" onclick="window.open(this.href);return false;
" onclick="window.open(this.href);return false;

Note: If you want/need any extra info let me know so i can ask for you!



Post Reply
  • Similar Topics
    Replies
    Views
    Last post